PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) HTML/CSS rendering issues Unable to use pd4ml.extra.resource.loaders

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27031

    I am chasing an issue where PD4ML is not able to fetch https images. We are using PD4ML 380fx6 Pro from a tomcat environment. Based on previous posts, my theory is that I need to create a class for pd4ml.extra.resource.loaders.

    Using the sample on this board, I have created my own com.mycompany.utilities.PD4MLCustomFileResourceProvider.class. I have also added the code to add this as the DynamicParams.

    HashMap map = new HashMap();<br /> map.put( "pd4ml.extra.resource.loaders", "PD4MLCustomFileResourceProvider" );<br /> pd4ml.setDynamicParams(map);<br /> pd4ml.enableDebugInfo();<br /> pd4ml.render(sr, os);

    But when I run the code, I see in the logs:

    version: PD4ML 380fx6 Pro
    image not yet in cache: http://www.google.com/images/srpr/logo11w.png
    not yet in cache: http://www.google.com/images/srpr/logo11w.png
    External resource loader: PD4MLCustomFileResourceProvider not found. Make sure “pd4ml.extra.resource.loaders” value is correct
    External resource loader: PD4MLCustomFileResourceProvider not found. Make sure “pd4ml.extra.resource.loaders” value is correct
    image size: 14022

    Do I need to include the package information in the Map?

    TIA!
    Steve B.

    #29793

    I’m having the same problem.

    How can I set value to “pd4ml.extra.resource.loaders”?

    #29794

    Steve B. (see previous posts) finally solved the issue by a prepending the class name with its full package name, i.e:

    map.put( “pd4ml.extra.resource.loaders”, “com.application.PD4MLCustomFileResourceProvider” );

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘HTML/CSS rendering issues’ is closed to new topics and replies.