PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) Troubleshooting TTF issues Pro Eval Version 3.8 vs 3.7

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26662

    I have run into an issue ‘upgrading’ from pd4ml 3.70fx2 to 3.8. I am using the Pro evaluation verions. I am using TTF fonts and what worked in 3.7 no longer does in 3.8. I am using just a basic Java app rendering a test html page. Both are attached. Changing only the pd4ml library, the ‘Arial Narrow MT’ font now renders as plain Arial.

    Debug output:

    version: PD4ML 370fx2 Pro (eval)
    not yet in cache: java:tifonts/pd4fonts.properties
    not yet in cache: java:tifonts/Arial.ttf
    read ‘arial’ from java:tifonts/Arial.ttf
    not yet in cache: java:tifonts/Arial Bold.ttf
    read ‘arial bold’ from java:tifonts/Arial Bold.ttf
    not yet in cache: java:tifonts/Arial Italic.ttf
    read ‘arial italic’ from java:tifonts/Arial Italic.ttf
    not yet in cache: java:tifonts/Arial Bold Italic.ttf
    read ‘arial bold italic’ from java:tifonts/Arial Bold Italic.ttf
    not yet in cache: java:tifonts/ArialNarrow.ttf
    read ‘arial narrow mt’ from java:tifonts/ArialNarrow.ttf
    not yet in cache: java:tifonts/ArialNarrow-Bold.ttf
    read ‘arial narrow mt bold’ from java:tifonts/ArialNarrow-Bold.ttf
    not yet in cache: java:tifonts/ArialNarrow-Italic.ttf
    read ‘arial narrow mt italic’ from java:tifonts/ArialNarrow-Italic.ttf
    not yet in cache: java:tifonts/ArialNarrow-BoldItalic.ttf
    read ‘arial narrow mt bold italic’ from java:tifonts/ArialNarrow-BoldItalic.ttf
    not yet in cache: java:tifonts/Franklin Gothic Medium.ttf
    read ‘franklin gothic medium’ from java:tifonts/Franklin Gothic Medium.ttf
    ‘franklin gothic medium bold’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘franklin gothic medium bold’
    not yet in cache: java:tifonts/Franklin Gothic Medium Italic.ttf
    read ‘franklin gothic medium italic’ from java:tifonts/Franklin Gothic Medium Italic.ttf
    ‘franklin gothic medium bold italic’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘franklin gothic medium bold italic’
    ‘courier new’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘courier new’
    done in 863ms.

    version: PD4ML 380 Pro (eval)
    not yet in cache: java:tifonts/pd4fonts.properties
    not yet in cache: java:tifonts/Arial.ttf
    read ‘arial’ from java:tifonts/Arial.ttf
    ‘courier new’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘courier new’
    ‘ms gothic’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘ms gothic’
    ‘mingliu’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘mingliu’
    ‘simsun’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘simsun’
    ‘mangal’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘mangal’
    ‘david’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘david’
    ‘gulimche’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘gulimche’
    ‘wingdings’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘wingdings’
    ‘symbol’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘symbol’
    ‘lucida sans regular’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘lucida sans regular’
    not yet in cache: java:tifonts/Franklin Gothic Medium.ttf
    read ‘franklin gothic medium’ from java:tifonts/Franklin Gothic Medium.ttf
    ‘franklin gothic medium bold’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘franklin gothic medium bold’
    not yet in cache: java:tifonts/Franklin Gothic Medium Italic.ttf
    read ‘franklin gothic medium italic’ from java:tifonts/Franklin Gothic Medium Italic.ttf
    ‘franklin gothic medium bold italic’ is not in pd4fonts.properties file
    reject TTF lookup for: ‘franklin gothic medium bold italic’
    done in 851ms.

    Here is the simple html file:

    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"><br /> <head><br /> <title>TI</title><br /> <style type="text/css"><br /> *{font-family:"Arial";font-size:12px;vertical-align: top;}<br /> </style><br /> </head><br /> <body><br /> Default font<br><br><br /> <div style="font-family:'Arial';">Arial</div><br /> <div style="font-family:'Arial';font-weight:bold;">Arial Bold</div><br /> <div style="font-family:'Arial';font-style:italic">Arial Italic</div><br /> <div style="font-family:'Arial';font-weight:bold;font-style:italic">Arial Bold Italic</div><br /> <br><br /> <div style="font-family:'Arial Narrow MT';">Arial Narrow</div><br /> <div style="font-family:'Arial Narrow MT';font-weight:bold;">Arial Narrow Bold</div><br /> <div style="font-family:'Arial Narrow MT';font-style:italic">Arial Narrow Italic</div><br /> <div style="font-family:'Arial Narrow MT';font-weight:bold;font-style:italic">Arial Narrow Bold Italic</div><br /> <br><br /> <div style="font-family:'Franklin Gothic Medium';">Franklin Gothic Medium</div><br /> <div style="font-family:'Franklin Gothic Medium';font-weight:bold;">Franklin Gothic Medium Bold</div><br /> <div style="font-family:'Franklin Gothic Medium';font-style:italic">Franklin Gothic Medium Italic</div><br /> <div style="font-family:'Franklin Gothic Medium';font-weight:bold;font-style:italic">Franklin Gothic Medium Bold Italic</div><br /> </body><br /> </html>

    and the properties file:

    #Mon Jan 23 14:51:00 EST 2012
    Franklin Gothic Medium=Franklin Gothic Medium.ttf
    Franklin Gothic Medium Italic=Franklin Gothic Medium Italic.ttf
    Arial=Arial.ttf
    Arial Bold=Arial Bold.ttf
    Arial Bold Italic=Arial Bold Italic.ttf
    Arial Italic=Arial Italic.ttf
    Arial Narrow MT=ArialNarrow.ttf
    Arial Narrow MT Bold=ArialNarrow-Bold.ttf
    Arial Narrow MT Bold Italic=ArialNarrow-BoldItalic.ttf
    Arial Narrow MT Italic=ArialNarrow-Italic.ttf

    I’d appreciate any help. Thanks.

    — Cindy

    #28821

    We’ve just published a new version of PD4ML, which also addresses some TTF substitution issues. Please give it a try and let us know if it solves the problem on your side.

    #28822

    Yes, the new version did fix that issue. Thanks.

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘Troubleshooting’ is closed to new topics and replies.