PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) General questions / FAQ tag ‘span’ and "class" attribute

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26899

    That depends on where you define

    #29471

    @PD4ML wrote:

    Can you publish a minimalistic example, which illustrates the issue?

    Yes, i did it.

    This is source page:
    <br /> <!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml"><head><title>Title</title><meta content="Apache Tapestry Framework (version 5.3.7)" name="generator"/><meta content="text/html; charset=utf-8" http-equiv="content-type"/><link type="text/css" rel="stylesheet" href="/assets/1.0-SNAPSHOT/core/default.css"/><link type="text/css" rel="stylesheet" href="/assets/1.0-SNAPSHOT/jquery/themes/ui-lightness/jquery-ui-1.8.19.custom.css"/><style><br /> label,<br /> input,<br /> button,<br /> select,<br /> textarea {<br /> font-size: 14px;<br /> font-weight: normal;<br /> line-height: 20px;<br /> }<br /> label {<br /> display: block;<br /> margin-bottom: 5px;<br /> }<br /> .label,<br /> .badge {<br /> display: inline-block;<br /> padding: 2px 4px;<br /> font-size: 11.844px;<br /> font-weight: bold;<br /> line-height: 14px;<br /> color: #ffffff;<br /> text-shadow: 0 -1px 0 rgba(0, 0, 0, 0.25);<br /> white-space: normal;<br /> vertical-align: baseline;<br /> background-color: #999999;<br /> }<br /> .label:empty,<br /> .badge:empty {<br /> display: none;<br /> }<br /> .label {<br /> -webkit-border-radius: 3px;<br /> -moz-border-radius: 3px;<br /> border-radius: 3px;<br /> }<br /> .label-success,<br /> .badge-success {<br /> background-color: #468847;<br /> }<br /> .label-success[href],<br /> .badge-success[href] {<br /> background-color: #356635;<br /> }<br /> .btn .label,<br /> .btn .badge {<br /> position: relative;<br /> top: -1px;<br /> }<br /> .btn-mini .label,<br /> .btn-mini .badge {<br /> top: 0;<br /> }<br /> </style></head><body><span class="label label-success">Some text</span></body></html>
    “Some text” isn’t printed into final pdf/rtf

    BUT if I replace a bit:
    <body>Some text<span class="label label-success">Some text</span></body>

    I can see BOTH “Some text” strings into pdf/rtf

    #29472

    Same problem with tables:
    <body><br /> <table><br /> <tr><br /> <td><span class="label label-success">Some text1</span><br /> </td><br /> <td><br /> ups<br /> <span class="label label-success">Some text2</span><br /> </td><br /> </tr><br /> </table><br /> </body>

    I can see only “Some text2” in PDF/RTF.

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘General questions / FAQ’ is closed to new topics and replies.