PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) General questions / FAQ System Error: Stack Underflow

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #26906

    Hi,

    I use a Application Development product where I use PD4ML as a 3rd party tool. I recently upgraded to 3.9.8FX1 and I encountered the below error :

    [2015-11-02 16:46:17,947] java.lang.RuntimeException: stack underflow
    at org.zefer.css.y.Ã’00000(Unknown Source)
    at org.zefer.css.yb.o00000(Unknown Source)
    at org.zefer.css.f.Ã’00000(Unknown Source)
    at org.zefer.html.doc.css.c.Ã’0O000(Unknown Source)
    at org.zefer.html.doc.PD4MLHtmlParser.buildDocument(Unknown Source)
    at org.zefer.pd4ml.PD4ML.o00000(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)

    I’m new to this forum. Can someone point on how can I fix this issue.

    This issue is seen when using a simple HTML Block in reports.

    Regards,
    Mani.

    #29485

    I would recommend to give a try to the just released v398fx2. If the issue persists, an HTML sample with accompanying CSS resources would help to analyze the issue.

    #29486

    Hi,

    I upgraded to v398fx2 and tried the same. I still see the same issue.

    I don’t have any HTML code as such. Below is with what I’ve tested and encountered the error :




    Testing

    I don’t use any external css except inbuilt css in product.

    Regards,
    Mani.

    #29487

    nested to ?

    #29488

    Sorry, my bad.

    it’s




    Testing

    #29489

    Hii,

    Anyone on this?

    #29490

    yes. to be addressed by the forthcoming maintenance release.

    #29491

    I am currently testing v398fx3 pre-release and the issue is not reproducible.

    v398fx2 also work flawless with the HTML. Obviously it is a bug of older versions only.

    #29483

    Hi,

    I still see this issue after upgrading to the latest version.

    Looks like the issue is introduced after 3.9.5 version. I downgraded PD4ML version to 3.9.5 to get rid of this error.

    Can you please check if anything newly added or changed after 3.9.5 had introduced this issue?

    Regards,
    Mani.

    #29484

    Yes, it has been significantly changed: we switched from open source CSS Parser Project library to our own CSS parser/cascading engine. Obviously the issue is there.

    [language=java:1go4b2xd][2015-11-02 16:46:17,947] java.lang.RuntimeException: stack underflow
    at org.zefer.css.y.Ã’00000(Unknown Source)
    at org.zefer.css.yb.o00000(Unknown Source)
    at org.zefer.css.f.Ã’00000(Unknown Source)
    at org.zefer.html.doc.css.c.Ã’0O000(Unknown Source)
    at org.zefer.html.doc.PD4MLHtmlParser.buildDocument(Unknown Source)
    at org.zefer.pd4ml.PD4ML.o00000(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)
    at org.zefer.pd4ml.PD4ML.render(Unknown Source)[/language:1go4b2xd]

    Even if the issue not in the new CSS parser, there is a lot of adjustments in the main converter code.

    An HTML code sample (incl. its CSS resources) which 100% throws an exception on your site would help a lot to determine a problem reason.

    (I am afraid, the blank HTML is not the right sample – the exception is thrown by CSS parsing and the HTML does not refer to any CSS resources)

Viewing 10 posts - 1 through 10 (of 10 total)

The forum ‘General questions / FAQ’ is closed to new topics and replies.