PD4ML v4 Forums PD4ML Forums Technical questions / Troubleshooting Numerated lists are saved differently in RTF format by pd4ml v3 and v4

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #34006

    We observe differences in RTF file content for numerated lists generated in pd4ml v3 and v4. Please note, in view mode they look almost the same, only the files’ content differs.
    For example, there is a list styled to be lowercase-roman:
    <ol style="list-style-type: lower-roman;"> <li> <div>Inner 'li' tag 1.1.1</div> </li> <li> <div>Inner 'li' tag 1.1.2</div> </li> <li> <div>Inner 'li' tag 1.1.3</div> </li> </ol>

    When used pd4ml v3, the last list item in RTF file is stored as below (if open in lister or notepad):
    }}}\ql\par}\f2\i0\b0\fs20\ql{\pard \plain \f2\i0\b0\fs20\nowidctlpar{\*\hyphen2\hyphlead2\hyphtrail2\hyphmax0}\cf1\kerning1\hich\dbch\loch{\listtext\pard\f2\i0\b0\fs20\plain iii. }\ilvl2\ls3 \li1440\ri0\lin1440\rin0\fi-360{\rtlch \ltrch\loch\f2\i0\b0\fs20 {\pard\ql\li0\ri0\sl208\slmult0{\widctlpar\dbch\ql\cf1 Inner 'li' tag 1.1.3

    Please see there is triple i there iii.

    With pd4ml v4 the same list item is stored as:
    }}}\ql\par}\f1\i0\b0\fs20\ql{\pard \plain\ltrpar\ltrch \f1\i0\b0\fs20\nowidctlpar{\*\hyphen2\hyphlead2\hyphtrail2\hyphmax0}\cf1\kerning1\hich\dbch\loch{\listtext\pard\ltrpar\ltrch\f1\i0\b0\fs20\plain i. }\ilvl2\ls3 \li1440\ri0\lin1440\rin0\fi-360{\ltrpar\ltrch\loch\f1\i0\b0\fs20 {\pard\ltrpar\ltrch\li0\ri0\sl250\slmult0{\widctlpar\dbch\ql\ltrch\f1\i0\b0\fs20 Inner 'li' tag 1.1.3

    There is only single i there.

    Also, I’ve noticed that view mode in WordPad displays them differently as well.
    While in view mode in MS Word application both documents are displayed properly with iii. (the difference was found by automated tests), so I’m just wondering to confirm this is expected behavior in v4.

    Please see sample html, resulting rtf files and java code attached.

    Attachments:
    You must be logged in to view attached files.
    #34008

    Thank you for the report!

    We’ll address the issue and let you know as soon as there is a solution or workaround.

    #34009

    We’ll address the issue and let you know as soon as there is a solution or workaround.

    Thanks. Actually my goal was to clarify with you whether this is an issue or not.

    #34010

    If v3 and v4 RTF output differs in such details – it looks like an issue from our perspective. We are trying to keep RTF modules in v3 and v4 branches in sync.

    Unfortunately we cannot assign the high priority to the issue – right now there is a number of urgent tasks to be completed. But I hope we’ll manage to analyze it this week.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.