PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) HTML/CSS rendering issues HTML special char not print with the newest Pd4ml 394v

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26990

    Hi,
    I try to convert this html code in pdf with pd4ml jar library:

    <br /> <html><br /> <head></head><br /> <body><br /> <p><br /> Š<br /> </p><br /> </body><br /> </html><br />

    With 380 Pro version, Pd4ml renders it correctly, with the newest 394 (and with the prior 384), it’s not decode (render print “?” char).

    Attached the pdfs.

    Someone can help me?

    #29665

    The problem reason is that recent PD4ML versions are more strict by character encoding conversion.

    ISO-8859-1 (also called Latin-1) is identical to Windows-1252 (also called CP1252) except for the code points 128-159 (Š = 138). ISO-8859-1 assigns several control codes in this range. Windows-1252 has several characters, punctuation, arithmetic and business symbols assigned to these code points.

    As I see you use Windows-1252 as default; PD4ML relies on ISO-8859-1.

    A general solution for that type of issues is to utilize TTF embedding feature of PD4ML.

    As long as you run DMS edition of PD4ML, the easiest workaround would be to enable PDF/A generation mode (make sure pd4ml_rc.jar is in the same directory with pd4ml.jar) with pd4ml.generatePdfa(true) API call.

    #29666

    We enable PDF/A generation mode and it works correctly

    Many thanks

Viewing 3 posts - 1 through 3 (of 3 total)

The forum ‘HTML/CSS rendering issues’ is closed to new topics and replies.