PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) Troubleshooting image rendering not working for me (Websphere 4 on aix) Re: Re: image rendering not working for me (Websphere 4 on aix)

#27546

[SOLVED]

the host – “TestServer” above was a virtual host on another machine (eg HostA)
(HostA and TestServer share the same IP address).

HostA didnt have DNS enabled, so HostA could not ping TestServer.
However my desktop PC itself could ping both HostA and TestServer.

solution: (either enable DNS resolution – not allowed in my environment, or, add TestServer to the hosts file…)

Grrrrr
Now onto the rest of the prototype….

here is a copy of the file that is WORKING. (it renders the two pictures)

<pd4ml:transform<br /> screenWidth="800"<br /> pageFormat="A4"<br /> pageOrientation="portrait"<br /> pageInsets="10,10,10,10,points"<br /> enableImageSplit="false"<br /> encoding="default"<br /> fileName="myoutput.pdf"<br /> inline="true"<br /> debug="true"<br /> ><br /> <br /> <br /> <br /> <br /> <br /> <%<br /> String url = request.getScheme() + "://" +<br /> request.getServerName() + ":" +<br /> request.getServerPort() +<br /> request.getContextPath() + "/";<br /> %><br /> <BASE id="theBase" href=""><br /> <br /> <br /> <br /> <br /> Server Base Path = <br /> <BR><BR><br /> <br /> <br /> TEST 1<br /> Works Fine. This doesnt use the base tag resolution - it is already fully qualified.<br /> <IMG src="http://testServer/wayne/wayne/my_logo.jpg" width="200" height="200"><br /> <br /> TEST 2<br /> WORKS, this uses the base tag to determine the apps context etc... so its a way for me to use relative paths<br /> that resolve to fully qualified urls when you look at the log.<br /> <IMG src="wayne/my_logo.jpg"><br /> <br /> <BR><BR><br /> Hello, World A4!<br /> <br /> <br /> <br /> Hello, Page2!<br /> <br /> <br /> <br /> <br />