PD4ML v4 Forums PD4ML v3 Archived Forums (Read Only) HTML/CSS rendering issues style="whitespace: pre" is not working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #27026

    Hi all,

    Please refer to the following html code

    <!--?xml version="1.0" encoding="UTF-8"?--><html><head><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta http-equiv="X-UA-Compatible" content="IE=edge"></head><br /> <body><div id="j_idt44" class="ui-outputpanel ui-widget"><br /> <a id="anchorPageHeader"></a><br /> <div class="container" style="margin-bottom: 5%;"><br /> <div id="template" style="border: 2px solid #EAEAEA; margin-left: -1.92%; margin-right: 2%;"><br /> <div id="globalMessages" class="ui-messages ui-widget" aria-live="polite"></div><br /> <div style="padding: 0 20px 10px;" id="contentId"><br /> <form id="printSubmissionForm" name="printSubmissionForm" method="post"><br /> <input type="hidden" name="printSubmissionForm" value="printSubmissionForm"><br /> <div id="printSubmissionForm:j_idt1337" class="ui-panel ui-widget ui-widget-content ui-corner-all" data-widget="widget_printSubmissionForm_j_idt1337"><br /> <div id="printSubmissionForm:j_idt1337_header" class="ui-panel-titlebar ui-widget-header ui-helper-clearfix ui-corner-all"><br /> <span class="ui-panel-title">Particulars of Deceased</span><br /> </div><br /> <div id="printSubmissionForm:j_idt1337_content" class="ui-panel-content ui-widget-content"><br /> <table id="printSubmissionForm:j_idt1338" class="ui-panelgrid ui-widget panelEsvcColorClass" style="width: 100%;" role="grid"><br /> <tbody><br /> <tr class="ui-widget-content ui-panelgrid-even" role="row"><br /> <td role="gridcell" style="width:40%"> File Reference No.</td><br /> <td role="gridcell" style="width:60%"><span id="printSubmissionForm:fileRefNumDesc">XXXXXXXXX</span></td><br /> </tr><br /> <tr class="ui-widget-content ui-panelgrid-even" role="row"><br /> <td role="gridcell" style="width:40%"> Name</td><br /> <td role="gridcell" style="width:60%">XXXXX</td><br /> </tr><br /> </tbody><br /> </table><br /> </div><br /> </div><br /> <div id="printSubmissionForm:j_idt1357" class="ui-panel ui-widget ui-widget-content ui-corner-all" data-widget="widget_printSubmissionForm_j_idt1357"><br /> <div id="printSubmissionForm:j_idt1357_header" class="ui-panel-titlebar ui-widget-header ui-helper-clearfix ui-corner-all"><br /> <span class="ui-panel-title">Particulars of Child</span><br /> </div><br /> <div id="printSubmissionForm:j_idt1357_content" class="ui-panel-content ui-widget-content"><br /> <table id="printSubmissionForm:j_idt1358" class="ui-panelgrid ui-widget panelEsvcColorClass" style="width: 100%;" role="grid"><br /> <tbody><br /> <tr class="ui-widget-content ui-panelgrid-even" role="row"><br /> <td role="gridcell" style="width:40%"> Name (as in Birth Certificate/NRIC No.)</td><br /> <td role="gridcell" style="width:60%"><span id="printSubmissionForm:childNme">XXXXX (XXXX8719D)</span></td><br /> </tr><br /> <tr class="ui-widget-content ui-panelgrid-odd" role="row"><br /> <td role="gridcell" style="width:40%"> Any other name(s)</td><br /> <td role="gridcell" style="width:60%"><span id="printSubmissionForm:childOthNme" class="textarea" style="white-space:pre">TEST 123<br /> TEST</span></td><br /> </tr><br /> <tr class="ui-widget-content ui-panelgrid-even" role="row"><br /> <td role="gridcell" style="width:40%"> NRIC/ Passport No.</td><br /> <td role="gridcell" style="width:60%">XXXXXXXX <span> : </span>XXXX8719D</td><br /> </tr><br /> <tr class="ui-widget-content ui-panelgrid-odd" role="row"><br /> <td role="gridcell" style="width:40%"> Education Level</td><br /> <td role="gridcell" style="width:60%"><span id="printSubmissionForm:childEduLevelCde">PRIMARY 1</span></td><br /> </tr><br /> </tbody><br /> </table><br /> </div><br /> </div><br /> </form><br /> </div><br /> </div><br /> </div><br /> </div></body></html>

    in the “Any Other Name(s)” field, I have inserted a new line after “TEST 123”, the styling works correctly when I open the HTML file in a browser.

    When I try to generate a pdf using the same file, there is no new line being displayed after “TEST 123”.

    In summary, i want the value to be printed like this:
    TEST 123
    TEST

    instead, i got this:
    TEST 123 TEST

    Based on the documentation, PD4ML does support the style so I am wondering what I am doing wrong.

    Thanks a bunch for your help.

    #29763

    Current versions of PD4ML provide a limited functionality for tag.

    You can achieve the needed layout if you move style=”whitespace: pre” from to hosting

    tag.

Viewing 2 posts - 1 through 2 (of 2 total)

The forum ‘HTML/CSS rendering issues’ is closed to new topics and replies.